It is currently 15 Dec 2018, 05:28
Join the free forum or login with your account and the annoying banner goes away

Fiberglasssupplydepot

All times are UTC - 5 hours [ DST ]




 Page 2 of 2 [ 17 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Getting too hot?
PostPosted: 20 Sep 2016, 17:42 
User avatar

Joined: 27 Nov 2010, 09:36
Posts: 4721
Location: Houston, TX & Crossville, TN
Kind of reminded me of the old Wankel rotary engine. It was going to revolutionize auto motors. Too much pollution killed it, I think. richg99



_________________
“Busy is a choice. Stress is a choice. Joy is a choice. Choose well.”.....Ann Voskamp
Offline
 Profile  
 
 Post subject: Getting too hot?
PostPosted: 26 Sep 2016, 20:49 

Joined: 13 Nov 2014, 08:01
Posts: 755
Happy ending to the story here.

Got the new impeller, but it was too thick & didn't work (I saw posts on iboats that others had same outcome).

On a hunch, I took lower unit apart & dug out the water tube seal. The tube OD is 1/4 inch and the seal ID is 5/16.

No wonder the water wasn't going uphill.

I surmise that someone put the wrong seal in ( it looks pretty new).

I made a collar for the tube to match diameters & now it pumps like a champ.

It is idling better too.

Thanks for your help guys.


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 2 of 2 [ 17 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 38 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Join the free forum or login with your account and the annoying banner goes away

RazorBaits